• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Dodawanie tylko ujemnych liczb

Jeden z czytelników mojego bloga zadał następujące pytanie:

Jak dodać do siebie tylko ujemne wartości w dwóch komórkach, gdzie w jednej jest wprowadzona liczba a w drugiej jest wynik dzielenia tj np =(H38/2)+(H22), przy czym jeżeli wystąpi dodatnia liczba to ma być potraktowana jako zero.

W tym poście odpowiem na to pytanie.

Założenia sumowania:

1. Suma tylko wartości ujemnych

2. Wartości dodatnie mają zostać potraktowane jak zero.

Oto tabela z danymi:

Dodawanie tylko ujemnych liczb - formatka

W kolumnach Liczba1 i Liczba2 znajdują się liczby, które są dzielone w kolumnie Liczba1/Liczba2. Użyłam do tego następującej formuły (zabezpieczenie przed dzieleniem przez 0):

=JEŻELI.BŁĄD(A2/B2;0)

Wynik dzielenia w kolumnie Liczba1/Liczba2 oraz liczba w kolumnie Liczba3 mają zostać zsumowane na przedstawionych wyżej warunkach. Najłatwiej to zrobić w taki sposób:

1. W komórce E2 (kolumna Dzielenie mod) wpisz następującą formułę:

=JEŻELI(C2>0;0;C2)

2. W komórce F2 (kolumna Liczba3 mod) wpisz następującą formułę:

=JEŻELI(D2>0;0;D2)

3. W komórce G2 (kolumna Suma) wpisz następującą formułę:

=SUMA(E2:F2)

Oto wynik:

Dodawanie tylko ujemnych liczb - wynik

Można to oczywiście zapisać za pomocą jednej formuły, jednak moim zdaniem będzie to o wiele bardziej skomplikowane.

Gotowe!


Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych





Otagowany .Dodaj do zakładek permalink.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *