• Zapisz się do newslettera, aby otrzymywać powiadomienia o nowościach na blogu
    Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Kto ma urodziny w ciągu 2 miesięcy?

Jedna z czytelniczek mojego bloga zadała następujące pytanie:

W arkuszu “Arkusz1: mam dane w których są pola “imię” “nazwisko” “data urodzenia”. W jaki sposób do “Arkusz2” wrzucić tylko te dane osób, które mają urodziny w ciągu 2 miesięcy?

W tym poście pokażę w jaki sposób zdecydować, które osoby mają urodziny w ciągu 2 miesięcy. Posiadając taką informację – za pomocą na przykład autofiltru – można już bardzo łatwo skopiować dane tych osób do innego arkusza.

Szkolenie on-line z Excela - więcej informacji...

Tabela z danymi wygląda następująco:

Najpierw ustalmy datę graniczną, czyli tę “za 2 miesiące”. Aby to zrobić, w komórkę D2 wpisz następującą formułę:

=DATA(ROK(DZIŚ());MIESIĄC(DZIŚ())+2;DZIEŃ(DZIŚ()))

Teraz zajmę się ustalaniem pozostałych danych:

1. Najbliższe urodziny: wpisz do komórki D5 następującą formułę i skopiuj ją poniżej:

=DATA(ROK($D$2)+JEŻELI(DATA(ROK($D$2);MIESIĄC(C5);DZIEŃ(C5))<DZIŚ();1;0);MIESIĄC(C5);DZIEŃ(C5))

2. Urodziny w ciągu 2 miesięcy: wpisz do komórki E5 następującą formułę i skopiuj ją poniżej:

=JEŻELI(ORAZ(D5>=DZIŚ();D5<=$D$2);"tak";"")

Można oczywiście połączyć obie formuły zagnieżdżając je w sobie, jednak powstała w ten sposób formuła będzie bardzo długa, przez co nieczytelna. Polecam więc rozbić ją na 2 oddzielne formuły tak, jak to zrobiłam powyżej.

Oto wynik:

Aby umieścić dane osób, które mają urodziny w przeciągu 2 miesięcy należy:

1. Założyć na tabelę autofiltr (Dane/Sortowanie i filtrowanie/Filtruj)
2. Wybrać z pola Urodziny w ciągu 2 miesięcy rekordy posiadające wpis tak
3. Skopiować wyfiltrowane dane do innego arkusza.

Gotowe!

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o o nowościach na blogu.

Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Tagi .Dodaj do zakładek Link.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *