• Zapisz się na newsletter, aby otrzymywać powiadomienia o najnowszysch wpisach.

Niestandardowe zmniejszanie sumy w zależności od wpisu w kolumnie obok

Czyli kolejne wykorzystanie genialnej LICZ.JEŻELI

Dzisiaj króciutko o tym jak os dumy wartości w komórkach odjąć 1, za każdym razem, jak w komórce wystąpi określone słowo, np. „brak”. Artykuł ten jest odpowiedzią na pytanie Pawła, który właśnie miał taki case do rozwiązania. Jedyne co zmieniłam, to słowo: u Pawła było „b/ś”, a ja dałam „brak”, bo tak mi bardziej pasuje. Oczywiście słowo może być dowolne – trzeba je tylko wpisać do formuły 🙂

Oto formatka:

Formatka

Formatka

Do dzieła!

Tak na prawdę do zrobienia jest jedna krótka formułka. Zdefiniujmy sobie problem jeszcze raz: od sumy wszystkich wartości należy odjąć liczbę wystąpień słowa „brak” na liście z wartościami.

Sumę wszystkich policzy po prostu funkcja SUMA, a liczbę wystąpień słowa „brak” – funkcja LICZ.JEŻELI.

Sama formuła w komórce C3 wygląda więc następująco:

=SUMA(C4:C13)-LICZ.JEŻELI(C4:C13;"brak")

Króciutkie wyjaśnienie”: funkcja LICZ.JEŻELI liczy w tym wypadku liczbę wystąpień słowa „brak” w zakresie wskazanym w jej pierwszym argumencie.

Suma wartości w przykładzie wynosi 37, a po odjęciu dwóch „braków” dostajemy w wyniku liczbę 35.

Taka prosta rzecz, a cieszy 🙂

Wynik

Wynik

A tutaj film, pokazujący pisanie formuły krok po kroku:

 

 

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).


Tagi , , .Dodaj do zakładek Link.

2 odpowiedzi na „Niestandardowe zmniejszanie sumy w zależności od wpisu w kolumnie obok

  1. Paweł mówi:

    Rewelacja, wielkie dzięki 😀 O to dokładnie mi chodziło!

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *