• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Obliczanie czasu pracy: przerwy niewliczane do czasu pracy

Dziś pokażę jak obliczyć czas pracy w przypadku, gdy nie mają być wliczane w niego przerwy. Jest to odpowiedź na pytanie jednego z czytelników mojego bloga, które brzmi tak:

Jak poprawić formułę pokazaną w poście Tygodniowy czas pracy i nadgodziny, jeżeli mam podaną przerwę w pracy np. od 12:00 – 13:00, a nie chcę jej wliczać w łączny czas pracy?

Tak wyglądają dane:

Przerwy niewliczane do czasu pracy - formatka

Pokażę tutaj jak obliczyć czas pracy bez przerw oraz liczbę godzin nadliczbowych. Obliczanie wynagrodzenia znajdziesz w artykule: Tygodniowy czas pracy i nadgodziny.

Aby obliczyć czas pracy należy:

1. W komórce F2 wpisać następującą formułę:

=C2-B2-(E2-D2)

a następnie skopiować ja do pozostałych komórek.

2. W komórce G2 wpisać następującą formułę:

=JEŻELI(F2>=8/24;F2-8/24;0)

a następnie skopiować ja do pozostałych komórek – najlepiej za pomocą kombinacji klawiszy Ctrl + Enter.

Oto wynik:

Przerwy niewliczane do czasu pracy - wynik

I wszystko :)

Jeśli interesuje cię znacznie łatwiejsze potraktowanie odliczania przerw od czasu pracy – zachęcam do przeczytania tego artykułu: Jak odliczyć przerwy od przepracowanego czasu? Zachęcam do lektury!


Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych





Otagowany .Dodaj do zakładek permalink.

9 odpowiedzi na „Obliczanie czasu pracy: przerwy niewliczane do czasu pracy

  1. Anonymous mówi:

    a jak obliczyć spóźnienia? :) pomocy!!!

    • Malina C. mówi:

      A co dokładnie chcesz otrzymać? Jeśli satysfakcjonuje Cię jedynie odliczenie spóźnień od czasu pracy, to postąp analogicznie do tego, jak opisałam w tym artykule. A jak nie – będziemy coś kombinować (tylko koniecznie sprecyzuj) :)

      Pozdrawiam
      Malina

    • Anonymous mówi:

      nadgodziny działają, proszę o wzór – nie jestem dobra w excelu :/

  2. Anonymous mówi:

    nadgodziny działają, proszę o wzór – nie jestem dobra w excelu :/

  3. Wiesz może jak wygląda funkcja ‚jeżeli’ w arkuszu google?

  4. Bartek mówi:

    Wpisując formułę
    =JEŻELI(F2>=8/24;F2-8/24;0)
    Ecxcell zwraca mi same zera.
    Dzieje się tak przy wartościach typu 12:00 w komórce F2
    Przy wartości komórki F2 jest12, to wartości są obliczane prawidłowo.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *