• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Film: Suma czasu pracy w projektach wyodrębniana formułą tablicową

Niedawno pomagałam Leszkowi w zsumowaniu czasu pracy w grafiku, w którym notował przepracowane godziny łącznie z nazwą projektu. Były wiec tam wpisy typu 8A1, gdzie 8 to przepracowane godziny, a A1 to symbol projektu, w którym pracował pracownik. Zaproponowana przeze mnie formuła liczyła łączny czas pracy, a jak się później okazało, Leszek chciał również czas pracy w podziale na projekty. Zmodyfikowałam więc trochę tabelkę wynikową i formuły i udało się to osiągnąć. Jak – o tym jest najnowszy film.

Użyte formuły to:

1. Formuła licząca czas pracy w projekcie:

=SUMA(JEŻELI.BŁĄD(--LEWY($B3:$AF3;SZUKAJ.TEKST(AG$2;$B3:$AF3)-1);0))

2. Łączny czas pracy w miesiącu:

=SUMA(AG3:AH3;B3:AF3)

Oraz plik do pobrania:

Plik do pobrania:

 

 

 

Funkcja PRZESUNIĘCIE pomaga liczyć podsumy

Ostatnio napisał do mnie Radek z ciekawym pytaniem. Miał on bardzo dużą, dość specyficznie zbudowaną tabelę, w której chciał zastosować podsumowania części danych (coś á la sumy częściowe). Na koniec chciał mieć sumę wszystkiego. Radek się zastanawiał, czy da się to zrobić za pomocą jednej formuły. Przyznam, że rozwiązanie do oczywistych nie należy i jest bardzo ciekawe, bo zawiera funkcję PRZESUNIĘCIE…

Formatka wygląda tak:

Przesunięcie formatka

Formatka

W żółtej komórce F3 ma się znaleźć suma wszystkich wartości, a te wartości mają być takie:

  1. Tam, gdzie są szare pola, a w kolumnie B jednostką jest „ryczałt”, należy podsumować wszystkie dane pod tym ryczałtem (aż do następnego ryczałtu),
  2. Tam, gdzie jednostka jest inna niż „ryczałt”, należy pomnożyć wartości z kolumn C i D.

W kolumnie E są formuły wstawione ręcznie w odpowiednie komórki, które sumują tam, gdzie jest „ryczałt”, a w pozostałe komórki wstawione jest proste mnożenie (plik z rozwiązaniem znajdziesz na końcu artykułu). Sam przyznasz, że jest to mrówcza praca, a w całym ćwiczeniu chodzi o to, aby użyć jednej formuły. Do dzieła! 🙂

Czytaj dalej