• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Film: Suma czasu pracy w projektach wyodrębniana formułą tablicową

Niedawno pomagałam Leszkowi w zsumowaniu czasu pracy w grafiku, w którym notował przepracowane godziny łącznie z nazwą projektu. Były wiec tam wpisy typu 8A1, gdzie 8 to przepracowane godziny, a A1 to symbol projektu, w którym pracował pracownik. Zaproponowana przeze mnie formuła liczyła łączny czas pracy, a jak się później okazało, Leszek chciał również czas pracy w podziale na projekty. Zmodyfikowałam więc trochę tabelkę wynikową i formuły i udało się to osiągnąć. Jak – o tym jest najnowszy film.

Użyte formuły to:

1. Formuła licząca czas pracy w projekcie:

=SUMA(JEŻELI.BŁĄD(--LEWY($B3:$AF3;SZUKAJ.TEKST(AG$2;$B3:$AF3)-1);0))

2. Łączny czas pracy w miesiącu:

=SUMA(AG3:AH3;B3:AF3)

Oraz plik do pobrania:

Plik do pobrania:

 

 

 

Film: suma czasu pracy wyodrębniana formułą tablicową

Z problemem zaprezentowanym w dzisiejszym filmie przyszedł do mnie Leszek, który potrzebował obliczyć sumę przepracowanych godzin, które to musiał wyodrębnić z tekstu, np: z tekstu 8A1 potrzebował zsumować 8. W zaprezentowanym w filmie rozwiązaniu używam do tego formuły tablicowej oraz funkcji tekstowych: LEWY, SZUKAJ.TEKST i DŁ, oraz SUMA i JEŻELI.

Jeśli chcesz poznać sposób na obliczenie czasu pracy w poszczególnych projektach, to znajdziesz go tutaj. Nagrałam o tym kolejny film.

Oto film:

 

I jeszcze obiecana w filmie formuła (pamiętaj o zatwierdzeniu jej Ctrl + Shift + Enter):

=SUMA(JEŻELI(DŁ(B3:AF3)<3;B3:AF3;--LEWY(B3:AF3;SZUKAJ.TEKST("A";B3:AF3)-1)))

Oraz plik do pobrania:

 

 

Film: Pula urlopu w godzinach

Z problemem zgłosiła się do mnie czytelniczka, która prowadziła tabelkę z informacją ile godzin pracowała w danym dniu, a ile spędziła na urlopie. godzinami pracy i urlopu. Chciała dokonać prostego podsumowania godzin urlopu: ile jeszcze może go wykorzystać?

A oto zaproponowane przeze mnie rozwiązanie:

 

Czytaj dalej