• Zapisz się na newsletter, aby otrzymywać powiadomienia o najnowszysch wpisach.

Wynagrodzenie za nadgodziny 50% i 100%

Czyli wkopuję się głębiej w temat wynagrodzenia za nadgodziny

Zapytaliście mnie bowiem, jak obliczyć wysokość dodatków 50% i 100% za nadgodziny dobowe. W tym wpisie pokazuję najprostszą na świecie metodę na to. Ponieważ jednak jest najprostsza – wymaga od użytkownika ręcznego zdefiniowana, za które nadgodziny należy się dodatek 50%, a za które 100%. Zdaję sobie więc sprawę, że wpis ten nie wyczerpie tematu rozliczania nadgodzin, natomiast mam nadzieję, że znacznie go uprości.

Wpis ten jest jednocześnie kontynuacją ostatnio poruszanych na blogu tematów nadgodzin i wynagrodzenia za nie. O obliczaniu nadgodzin (czyli formuły w kolumnach E, F i G z poniższego obrazka) możesz przeczytać tutaj.

Wynagrodzenie za nadgodziny 50 i 100 Malinowy Excel

Formatka jest rozszerzeniem tych z poprzednich wpisów i wygląda tak:

Formatka

Formatka

Do ręcznego uzupełnienia jest tym razem kolumna Rodzaj ndg, komórka z wymiarem etatu F3 i z wynagrodzeniem godzinowym (F4). Pozostałe żółte pola, czyli obliczanie liczby nadgodzin 50% i 100% oraz wynagrodzenie za nie – będą to formuły, omówione niżej.

1. Obliczanie liczby nadgodzin 50% i 100%

Tutaj chcemy podsumować liczbę godzin nadliczbowych, ale tylko takich, za które należy się dodatek 50% lub 100%. Jak już je obliczymy, odejmiemy od nich już odebrane godziny każdego typu. Nie chcemy za nie wypłacać wynagrodzenia.

Czyli jak interesują nas nadgodziny 50% to chcemy podsumować te nadgodziny z kolumny Ndg, które w kolumnie Rodzaj ndg mają wpis 50%. Następnie, na tej samej zasadzie, odejmujemy od nich już odebrane godziny, czyli z kolumny Odebrane.

Idealna do tego będzie funkcja SUMA.JEŻELI. Zobaczcie formułę w komórkach D19 i D20 (dla 50% i 100% jedna formuła do skopiowania):

=SUMA.JEŻELI($H$7:$H$14;C19;$F$7:$F$14)-SUMA.JEŻELI($H$7:$H$14;C19;$G$7:$G$14)

Dzięki temu, że mam tak skonstruowaną formatkę, że wartości 50% i 100% mam wpisane w oddzielne komórki – w powyższej formule mogę się do nich na spokojnie odwołać, dzięki czemu wystarczy ta jedna formuła dla obu rodzajów nadgodzin. Oczywiście muszą też być poblokowane zakresy – bez tego ani rusz 😉

Dostajemy w efekcie coś takiego:

Liczba nadgodzin

Liczba nadgodzin

2. Wynagrodzenie za nadgodziny

Obliczenie wynagrodzenia za te nadgodziny to już pikuś. Zrobię to identycznie jak na tym filmie (na nim dokładnie tłumaczę skąd się wzięło mnożenie *24).

Formuła w komórkach H19 i H20 jest taka:

=D19*24*$F$4*(1+G19)

Kolejność mnożenia oczywiście dowolna.

Ze wszystkiego wychodzi nam to:

Wynik

Wynagrodzenie za nadgodziny 50% i 100%

I to tyle. Takie to proste.

Poniżej plik do pobrania (w wygodniejszej do wpisywania dużej liczby danych wersji):MalinowyExcel_Wynagrodzenie za nadgodziny 50 100 tabela dw.xlsx

I film, na którym krok po kroku prezentuję opisane rozwiązanie:

Enjoy!

 

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).


Tagi , , , , , , , , .Dodaj do zakładek Link.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *