• Zapisz się na newsletter, aby otrzymywać powiadomienia o najnowszysch wpisach.

Podsumowanie tygodniowych nadgodzin – SUMA.JEŻELI lub SUMA.ILOCZYNÓW

Wpis ten pokazuje metodę na obliczenie nadgodzin w pewnym okresie, zakładając, że nadgodziny to wszystkie godziny przepracowane ponad etat i w weekendy. W poprzednim wpisie pokazywałam jak to zrobić z kolumnami pośredniczącymi, w których krok  po kroku są obliczane czas pracy, godziny nadliczbowe i godziny, które pracownik odebrał.

W dzisiejszym filmie pokazuję zaś jak to zrobić tylko na podstawie daty (tutaj mamy informację o dniu tygodnia) i godzin pracy.

Pokazuję 2 sposoby na obliczenie tego:

  1. z kolumną pośredniczącą, przy użyciu funkcji SUMA.JEŻELI i LICZ.JEŻELI
  2. bez kolumny pośredniczącej, za pomocą formuł tablicowych, używających funkcji SUMA.ILOCZYNÓW (nie trzeba zatwierdzać kombinacją klawiszy Ctrl + Shift + Enter)

Oba rozwiązania omawiam na filmie:

A tutaj możesz skopiować użyte formuły:

1. Wersja z kolumną pośredniczącą

Dzień tygodnia (G6):

=DZIEŃ.TYG(B6;2)

Godziny w tygodniu

=SUMA.JEŻELI(G6:G13;"<=5";E6:E13)

Należnych godzin

=LICZ.JEŻELI(G6:G13;"<=5")*E3

Nadgodziny w tygodniu (formuła taka sama dla obu wersji)

=F16-F17

Nadgodziny w weekendy

 =E14-F16

2. Wersja tablicowa

Godziny w tygodniu

=SUMA.ILOCZYNÓW(--(DZIEŃ.TYG(B6:B13)<6);E6:E13)

Należnych godzin

=SUMA.ILOCZYNÓW(--(DZIEŃ.TYG(B6:B13)<6))*E3

I na koniec plik do pobrania:

 

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).


Tagi , , , , , , .Dodaj do zakładek Link.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *