• Zapisz się do newslettera, aby otrzymywać powiadomienia o nowościach na blogu
    Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Podsumowanie tygodniowych nadgodzin – SUMA.JEŻELI lub SUMA.ILOCZYNÓW

Wpis ten pokazuje metodę na obliczenie nadgodzin w pewnym okresie, zakładając, że nadgodziny to wszystkie godziny przepracowane ponad etat i w weekendy. W poprzednim wpisie pokazywałam jak to zrobić z kolumnami pośredniczącymi, w których krok  po kroku są obliczane czas pracy, godziny nadliczbowe i godziny, które pracownik odebrał.

W dzisiejszym filmie pokazuję zaś jak to zrobić tylko na podstawie daty (tutaj mamy informację o dniu tygodnia) i godzin pracy.

Pokazuję 2 sposoby na obliczenie tego:

  1. z kolumną pośredniczącą, przy użyciu funkcji SUMA.JEŻELI i LICZ.JEŻELI
  2. bez kolumny pośredniczącej, za pomocą formuł tablicowych, używających funkcji SUMA.ILOCZYNÓW (nie trzeba zatwierdzać kombinacją klawiszy Ctrl + Shift + Enter)

Oba rozwiązania omawiam na filmie:

Szukasz szkolenia z Excela dla HR?

Mogę je dla Ciebie poprowadzić tradycyjnie lub on-line

Najbliższy termin: 20-21 września 2018
(szkolenie stacjonarne, Warszawa)

Zobacz szczegóły

A tutaj możesz skopiować użyte formuły:

1. Wersja z kolumną pośredniczącą

Dzień tygodnia (G6):

=DZIEŃ.TYG(B6;2)

Godziny w tygodniu

=SUMA.JEŻELI(G6:G13;"<=5";E6:E13)

Należnych godzin

=LICZ.JEŻELI(G6:G13;"<=5")*E3

Nadgodziny w tygodniu (formuła taka sama dla obu wersji)

=F16-F17

Nadgodziny w weekendy

 =E14-F16

2. Wersja tablicowa

Godziny w tygodniu

=SUMA.ILOCZYNÓW(--(DZIEŃ.TYG(B6:B13)<6);E6:E13)

Należnych godzin

=SUMA.ILOCZYNÓW(--(DZIEŃ.TYG(B6:B13;2)<6))*E3

I na koniec plik do pobrania:

 

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o o nowościach na blogu.

Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Tagi , , , , , , .Dodaj do zakładek Link.

2 odpowiedzi na „Podsumowanie tygodniowych nadgodzin – SUMA.JEŻELI lub SUMA.ILOCZYNÓW

  1. Bartek mówi:

    Cześć,
    fajny poradnik.
    w wersji tablicowej, do funkcji DZIEŃ.TYG powinnaś dodać jeszcze argument [zwracany_typ]=2, bo źle Ci wyznacza weekend. Wynik dostajesz prawidłowy, ale tylko przypadkiem, bo tak się akurat ułożyły godziny pracy 🙂

    pozdrawiam

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *