• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Przeterminowane faktury

Pokażę wam dziś jak sprawdzić, czy faktura jest przeterminowana. Temat szczególnie przydatny księgowym, ale nie tylko. Możemy bowiem sprawdzać termin wykonania zadania zleconego pracownikowi (to np. dla Project Managerów) czy termin ważności produktu spożywczego, czy jakiegoś kosmetyku. Zastosowań mnóstwo, a formuła i sposób sprawdzenia tego w Excelu – taki sam, niezależnie co sprawdzamy: faktury, deadline, szampon do włosów, jabłka czy gruszki 🙂

We wpisie będę sprawdzać faktury. Zobaczcie, tak wygląda mój arkusz:

Formatka

Formatka

Czyli będę chciała określić status faktury (czy jest przeterminowana, czy nie) i dodatkowo określę o ile dni jest przeterminowana. Na koniec, żeby dodać trochę grafiki, którą tak wszyscy kochamy :), zaznaczymy kolorem te wiersze, w których występuje faktura przeterminowana.

Uwaga! Ten wpis został rozszerzony o dodatkowy status, jeśli faktura została już zapłacona. Artykuł i plik do pobrania znajdziesz tutaj.

W komórce C3 wpisałam dzisiejszą datę za pomocą funkcji DZIŚ, czyli:

=DZIŚ()

Można oczywiście umieścić ją bezpośrednio w formule. Ja wybrałam tę formę, aby było bardziej czytelnie.

Określanie statusu faktury

Czyli mamy nr faktury i termin płatności. Kiedy zatem faktura jest przeterminowana? Kiedy jej termin płatności jest mniejszy niż dzisiejsza data. Ten właśnie warunek umieszczę w funkcji JEŻELI, w komórce C6 i kolejnych:

=JEŻELI(B6<$C$3;"przeterminowana";"")

Oczywiście zamiast słowa „przeterminowana” możecie umieścić dowolny tekst. Znaki cudzysłowia w trzecim argumencie oznaczają: nic nie wyświetlaj.

Po skopiowaniu formuły w dół (np. za pomocą tej metody – nie rozjedzie się wtedy formatowanie) efekt jest następujący:

Opis słowny

Opis słowny

Obliczanie liczby dni przeterminowania

Liczbę dni, o jakie faktura jest przeterminowana możemy również ustalić za pomocą funkcji JEŻELI. Ja znowu będę porównywać dzisiejszą datę do terminu płatności, ale można to oczywiście zrobić na podstawie ustalonego przed chwilą statusu.

Moja formuła jest taka:

=JEŻELI(B6<$C$3;$C$3-B6;0)

Jak widać praktycznie identyczna, co poprzednia – określająca status. A po skopiowaniu jej do pozostałych komórek, otrzymujemy taki efekt:

Liczba dni

Liczba dni

Zaznaczanie kolorem przeterminowanych faktur

Teraz pozostaje już tylko pokolorować wiersze (a może same komórki – jak chcecie), które zawierają przeterminowane faktury. Technika, którą teraz pokażę nie jest oczywista (uczestnikom moich szkoleń zawsze sprawia trochę problemu, ale tylko na początku :)).

Istotne jest, aby zaznaczyć zakres, który ma być pokolorowany. Aby kolorować całe wiersze, należy zaznaczyć zakres A6:D16 (jeśli chcecie kolorować tylko numery faktur – zaznaczcie A6:A16).

Następnie należy wejść do menu Narzędzia główne/ Formatowanie warunkowe/ Nowa reguła / Użyj formuły do określenia komórek, które należy sformatować. Pojawi się wtedy następujące okienko, w którym należy wpisać taką formułę, jak na obrazku:

Reguła formatowania warunkowego

Reguła formatowania warunkowego

Formuła jest taka (oczywiście można ustawiać inne reguły, np. opartą o status):

=$D6>0

Po wpisaniu tej formuły, koniecznie pamiętajcie o wybraniu formatu. Bez tego nie zobaczycie rezultatów (a wierzcie mi – nie ma nic bardziej frustrującego, jak szukanie błędu w formule, która jest dobrze napisana, tylko dlatego, że „nie koloruje” :)).

Ja wybrałam kolorowanie na pomarańczowo i uzyskałam taki efekt:

Wynik z formatowaniem warunkowym

Wynik z formatowaniem warunkowym

Tadam! I tyle. W sumie tak patrzę na tę tabelkę i trochę dziwnie wygląda to niebiesko-czerwone formatowanie. Lepiej byłoby ustawić wszystkie wiersze białe, a kolor mogłoby nadawać tylko formatowanie warunkowe. Kwestia gustu 🙂 Zróbcie tak, jak wam pasuje.

Na koniec pliczek z gotowcem do pobrania:

I wersja wideo:

Powiązany artykuł:

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych


Tagi , , , , .Dodaj do zakładek Link.

7 odpowiedzi na „Przeterminowane faktury

  1. Monika mówi:

    ogromnie dziękuję za gotowca:)

  2. Marcin Skrzypczak mówi:

    Witam

    Świetny artykuł i bardzo pomocny. Dziękuję 🙂
    Mam jednak pytanie. Czy istnieje możliwość stworzenia formuły która po wpisaniu np. obok, daty zapłaty za przeterminowaną już fakturę i wtedy w okienku zmieni się z przeterminowana na zapłacona oraz zniknie ilość dni po terminie i zaznaczenie kolorem ?
    Byłbym bardzo wdzięczny za udzielenie informacji.

    Z Pozdrowieniami
    Marcin

    • Malina mówi:

      Marcin, świetny pomysł! Oczywiście – da się zrobić. Napiszę o tym na blogu, bo myślę, że wieeele osób może mieć taki sam case 🙂

      Pozdrawiam
      Malina

  3. Xray mówi:

    Jak idą prace?

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *