fbpx

Ile jest unikalnych klientów w tabeli przestawnej?

31.01.2013 | Tabele przestawne

Czasem zachodzi potrzeba, aby określić ilość unikalnych wpisów w danej tabeli. Sytuację taką ilustruje poniższy przykład.

W tabeli mamy zestawienie dotyczące sprzedaży produktów klientom. Naszym celem jest dowiedzieć się jaki jest średni obrót na klienta w poszczególnych regionach sprzedaży.

Ile jest unikalnych wpisów - tabela z danymi

Jak widać zdarza się tak, że jeden klient kupił kilka razy. Nas jednak interesuje: ile klientów od nas kupiło, a nie ile razy klienci od nas kupowali. Potrzebujemy zatem policzyć unikalne wystąpienia nazwy klienta (w tym wypadku jest to wystarczająca identyfikacja klienta). Warto w tym celu wstawić do tabeli nową kolumnę – Unikalne, w której umieścimy licznik unikalnych wpisów.

Następnie w tej kolumnie wpisz następującą formułę:

=JEŻELI(LICZ.JEŻELI($A$2:A2;A2)>1;0;1)

Wynik przedstawia poniższy rysunek:

Ile jest unikalnych wpisów - wynik formuły

Po utworzeniu tabeli przestawnej, otrzymujemy następujący wynik:

Ile jest unikalnych wpisów - wykorzystanie w tabeli przstawnej

Uwaga! Pole PLN na klienta to pole obliczeniowe: = 'Wartość FV’ / 'Liczba firm’ (Liczba firm to nowa nazwa pola Unikalne).

Gdyby zamiast pola Unikalne użyć po prostu pola Klient, otrzymalibyśmy informację o liczbie faktur, a co za tym idzie – o średniej wartości na fakturę.

Gotowe!

Poniższy film pokazuje przedstawiony we wpisie case:

 

Zapisz się na bezpłatny mailing!

Zapisz się na bezpłatny mailing i otrzymaj bezpłatny e-book „10 najprzydatniejszych trików w Excelu”!

Newsletter Malinowy Excel | Bezpłatny e-book
Przeczytaj podobne wpisy

Kategorie

2 komentarze

  1. Krystian

    Ale po co się trudzić jak wystarczy wstawić tabele przestawna i na dole haczykiem „model danych”
    Potem we właściwościach masz możliwość wyliczania unikalnych wystąpień

    Odpowiedz
    • Malina

      Tak, wystarczy i o ty też mam wpis 🙂

      Odpowiedz

Wyślij komentarz

Twój adres e-mail nie zostanie opublikowany.

Pin It on Pinterest