• Zapisz się do newslettera, aby otrzymywać powiadomienia o nowościach na blogu
    Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Obliczanie czasu pracy: oznaczenie pracy w nocy

Post ten napisałam w odpowiedzi na pytanie jednego z czytelników mojego bloga. Jego pytanie brzmiało:

jak skonstruować formułę, aby zaznaczała które godziny są przepracowane jako “nocki”, tj. od 22.00 – 6.00, czy można ustalić tak, aby pokazywało np. literę N (czyli nocka)?

Do rozwiązania tego problemu przyjęłam następujące założenia:

  • pracownik pracuje w nocy (nocka) wtedy, kiedy przychodzi do pracy z datą o 1 dzień wcześniejszą niż wychodzi (np. przychodzi 13 stycznia a wychodzi 14 stycznia),
  • godzina rozpoczęcia pracy jest większa niż godzina jej zakończenia (np. rozpoczęcie: 22:00, zakończenie 6:00).

Szukasz szkolenia z Excela dla HR?

Mogę je dla Ciebie poprowadzić tradycyjnie lub on-line

Najbliższy termin: 20-21 września 2018
(szkolenie stacjonarne, Warszawa)

Zobacz szczegóły

Tabela danych wygląda następująco:

Czas pracy - oznaczenie pracy w nocy - formatka

Czyli interesuje nas godzina rozpoczęcia pracy oraz godzina jej zakończenia. Na podstawie tych dwóch danych możemy wyliczyć czas pracy (dodatkowo) oraz stwierdzić, czy pracownik pracował w nocy. Uwaga! Godzina 00:00 zalicza się do dnia następnego.

A oto kroki, które należy wykonać, aby obliczyć poszczególne dane:

1. Czas pracy: w komórkę D2 wpisz następującą formułę:

=C2-B2+JEŻELI(C2<B2;1;0)

2. Nocka: w komórkę E2 wpisz następującą formułę:

=JEŻELI(C2<B2;"nocka";"dzień")

3. Liczba nocek: w komórkę D9 wpisz następującą formułę:

=LICZ.JEŻELI(E2:E6;"nocka")

A oto wynik:

Czas pracy - oznaczenie pracy w nocy - wynik

Gotowe!

Artykuły pokrewne:

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o o nowościach na blogu.

Zapisując się, wyrażasz zgodę na przesyłanie Ci informacji o nowościach na tym blogu. Zgodę możesz w każdej chwili wycofać (szczegóły).

Tagi .Dodaj do zakładek Link.

2 odpowiedzi na „Obliczanie czasu pracy: oznaczenie pracy w nocy

  1. let mówi:

    Szukam takiej informacji: godzina nocna u mnie trwa od 22.00 do 6.00. Z grafiku tak wynika, że czasem kończę planowo o 22.15 czyli już w nocy. I co z tym 15 minutami ? Czy traktować to jako całą godzinę, czy zebrać cztery takie ćwierci , czy po prostu o tym zapomnieć ?
    Jeśli mógłbym prosić o odpowiedź na maila pomocniczego let16@wp.pl, bądź na ten mail który jest wymagany celem dodania komentarza.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *