• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Obliczanie czasu pracy: oznaczenie pracy w nocy

Post ten napisałam w odpowiedzi na pytanie jednego z czytelników mojego bloga. Jego pytanie brzmiało:

jak skonstruować formułę, aby zaznaczała które godziny są przepracowane jako „nocki”, tj. od 22.00 – 6.00, czy można ustalić tak, aby pokazywało np. literę N (czyli nocka)?

Do rozwiązania tego problemu przyjęłam następujące założenia:

  • pracownik pracuje w nocy (nocka) wtedy, kiedy przychodzi do pracy z datą o 1 dzień wcześniejszą niż wychodzi (np. przychodzi 13 stycznia a wychodzi 14 stycznia),
  • godzina rozpoczęcia pracy jest większa niż godzina jej zakończenia (np. rozpoczęcie: 22:00, zakończenie 6:00).

Tabela danych wygląda następująco:

Czas pracy - oznaczenie pracy w nocy - formatka

Czyli interesuje nas godzina rozpoczęcia pracy oraz godzina jej zakończenia. Na podstawie tych dwóch danych możemy wyliczyć czas pracy (dodatkowo) oraz stwierdzić, czy pracownik pracował w nocy. Uwaga! Godzina 00:00 zalicza się do dnia następnego.

A oto kroki, które należy wykonać, aby obliczyć poszczególne dane:

1. Czas pracy: w komórkę D2 wpisz następującą formułę:

=C2-B2+JEŻELI(C2<B2;1;0)

2. Nocka: w komórkę E2 wpisz następującą formułę:

=JEŻELI(C2<B2;"nocka";"dzień")

3. Liczba nocek: w komórkę D9 wpisz następującą formułę:

=LICZ.JEŻELI(E2:E6;"nocka")

A oto wynik:

Czas pracy - oznaczenie pracy w nocy - wynik

Gotowe!

Artykuły pokrewne:


Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych





Otagowany .Dodaj do zakładek permalink.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *