• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Obliczanie średniego czasu trwania czynności (np. biegu na 10 km)

Ostatnio napisała do mnie Dorota – czytelniczka mojego bloga. Zadała następujące pytanie:

Muszę w pracy wyliczyć średni czas przeprowadzania analizy próbek cito z kilku dni (ok. 100). (…) Do wyliczenia czasu trwania analizy pojedynczej próbki wzorowałam się na artykule Obliczanie czasu pracy. Nie wiem natomiast, jak wyliczyć średnią na podstawie wszystkich próbek?

Zatem w tym artykule pokażę, jak obliczyć średni czas trwania danej czynności. Omówię to na przykładzie biegu na 10 km. Będę potrzebowała do tego listy uczestników biegu (zawodników), a na niej godziny startu i końca biegu.

Oto dane:

Obliczanie średniego czasu (biegu na 10 km) - formatka

Najpierw obliczę czas trwania biegu poszczególnych zawodników. W tym celu należy w komórkę D2 wpisać następującą formułę:

=C2-B2

Po skopiowaniu formuły do pozostałych komórek (D2:D7) mogę już obliczać czas średni. Robię to następująco (komórka D9):

=ŚREDNIA(D2:D7)

Poniżej wynik:

Obliczanie średniego czasu - formatowanie minut

Średnia często jest liczbą z miejscami dziesiętnymi. Tak jest i w naszym przykładzie. Warto więc wyświetlić wynik w takiej postaci, aby były widoczne sekundy. Polecam więc użyć formatowania czasu z sekundami (obrazek poniżej). Aby wywołać okienko formatowania komórki, użyj skrótu klawiszowego Ctrl + 1 (jeden). Pojawi się następujące okienko (wybierz opcje zaznaczone na rysunku):

Obliczanie średniego czasu (biegu na 10 km) - formatowanie sekund

Oto efekt:

Obliczanie średniego czasu (biegu na 10 km) - wynik

I okazuje się, że średni czas biegu na 10 km zawodników z listy to prawie 54 minuty, a nie – 53! Opłacało się więc zmienić formatowanie 😉

Gotowe!

I wersja wideo:

 

Plik do pobrania: MalinowyExcel_Średni_czas.xlsx


Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych





Otagowany .Dodaj do zakładek permalink.

Jedna odpowiedź na „Obliczanie średniego czasu trwania czynności (np. biegu na 10 km)

  1. Jagoda C mówi:

    Super przykład. I ta zmiana formatowania zmieniła wynik.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *