• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Film: suma czasu pracy wyodrębniana formułą tablicową

Z problemem zaprezentowanym w dzisiejszym filmie przyszedł do mnie Leszek, który potrzebował obliczyć sumę przepracowanych godzin, które to musiał wyodrębnić z tekstu, np: z tekstu 8A1 potrzebował zsumować 8. W zaprezentowanym w filmie rozwiązaniu używam do tego formuły tablicowej oraz funkcji tekstowych: LEWY, SZUKAJ.TEKST i DŁ, oraz SUMA i JEŻELI.

Oto film:

 

I jeszcze obiecana w filmie formuła (pamiętaj o zatwierdzeniu jej Ctrl + Shift + Enter):

=SUMA(JEŻELI(DŁ(B3:AF3)<3;B3:AF3;--LEWY(B3:AF3;SZUKAJ.TEKST("A";B3:AF3)-1)))

Oraz plik do pobrania: