fbpx

Film: suma czasu pracy wyodrębniana formułą tablicową

17.05.2017 | Czas pracy, Formuły tablicowe, HR, Operacje na tekście, Tylko film

Z problemem zaprezentowanym w dzisiejszym filmie przyszedł do mnie Leszek, który potrzebował obliczyć sumę przepracowanych godzin, które to musiał wyodrębnić z tekstu, np: z tekstu 8A1 potrzebował zsumować 8. W zaprezentowanym w filmie rozwiązaniu używam do tego formuły tablicowej oraz funkcji tekstowych: LEWY, SZUKAJ.TEKST i DŁ, oraz SUMA i JEŻELI.

Jeśli chcesz poznać sposób na obliczenie czasu pracy w poszczególnych projektach, to znajdziesz go tutaj. Nagrałam o tym kolejny film.

Oto film:

I jeszcze obiecana w filmie formuła (pamiętaj o zatwierdzeniu jej Ctrl + Shift + Enter):

=SUMA(JEŻELI(DŁ(B3:AF3)<3;B3:AF3;--LEWY(B3:AF3;SZUKAJ.TEKST("A";B3:AF3)-1)))

Oraz plik do pobrania:

 

 

Zapisz się na bezpłatny mailing!

Zapisz się na bezpłatny mailing i otrzymaj bezpłatny e-book „10 najprzydatniejszych trików w Excelu”!

Newsletter Malinowy Excel | Bezpłatny e-book
Przeczytaj podobne wpisy

Kategorie

4 komentarze

  1. Justyna

    Super a jak policzyć gdy jest wszystko jednym rzędzie

    czas pracy/nadgodziny/odpracowanie 3 godz w innym dniu jesli powinien byc w pracy 8godz

    jak wyodrębnić dni wolne wpisujać tylko np 8/8/8/UW/KRW/L4/5/12

    UW+KRW+L4-24 godz

    Odpowiedz
    • Malina

      Hmmm, nie rozumiem co trzeba tutaj zrobić ;(

      Odpowiedz
  2. Justyna

    jak policzyć dni wolne czyli oznaczone jak poniżej

    jeden rząd UW +NŻ +UO itp a w osobnej komórce zlicza tekst na dni wolne np 3 bo UW+NŻ+UO to 3 dni wolne.

    Dziekuje

    Odpowiedz
    • Malina

      Sugerowałabym te dane umieścić w bazodanowym układzie i podliczyć wszystko w tabeli przestawnej 🙂

      Odpowiedz

Wyślij komentarz

Twój adres e-mail nie zostanie opublikowany.

Pin It on Pinterest