• Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

Zaokrąglanie liczb funkcją ZAOKR

Często zachodzi potrzeba zaokrąglenia liczby, np. do liczby całkowitej. Może się to przydać chociażby podczas rozliczania PITu, gdy trzeba zaokrąglić podstawę podatku do pełnych złotych lub obliczony podatek do pełnych złotych. Tutaj z pomocą przychodzi nam funkcja ZAOKR().
W tym przykładzie chcemy obliczyć podatek, jjaki należy zapłacić, kiedy podstawa podatku wynosi 1 964,50 zł. Najpierw będziemy zaokrąglać podstawę podatku do pełnych złotych, a następnie wyliczony podatek – też do pełnych złotych.

Zaokrąglanie liczb funkcją ZAOKR() - formatka

Liczba 1 964,5 zaokrąglona do liczb całkowitych (czyli złotówki zaokrąglone do pełnych złotych, czyli zero miejsc po przecinku) to 1 965 (0,5 zaokrąglamy w górę). Taki też wynik zwróci nam funkcja.

Do komórki B3 wpisz następującą formułę:

=ZAOKR(B1;0)

Chcemy bowiem zaokrąglić liczbę w komórce B1 (podstawę podatku) do liczb całkowitych, czyli do zera miejsc po przecinku (stąd jako drugi argument wpisujemy 0).

Aby obliczyć podatek 18% wpisz do komórki B4 taką formułę:

=B3*B2

Aby zaokrąglić otrzymaną wartość podatku do pełnych złotych, należy do komórki B5 wpisać następującą formułę:

=ZAOKR(B4;0)

Otrzymamy następujący wynik:

Zaokrąglanie liczb funkcją ZAOKR() - wynik

A teraz trochę teorii…

Składnia funkcji ZAOKR()

Składnia funkcji ZAOKR() jest bardzo prosta: należy podać jaką liczbę chcemy zaokrąglać i w jaki sposób. Poniższa tabela prezentuje przykładowe drugie argumenty funkcji ZAOKR() i jej wynik:

liczba

liczba_cyfr

wynik funkcji

opis

1264,556

2

1264,56

do 2 miejsc po przecinku
1264,556

1

1264,6

do 1 miejsca po przecinku
1264,556

0

1265

do liczb całkowitych
1264,556

-1

1260

do dziesiątek
1264,556

-2

1300

do setek
1264,556

-3

1000

do tysięcy

Jak widać, zaokrąglać można zarówno „po przecinku” jak i „przed przecinkiem”.

Uwaga! Pamiętaj, aby do zaokrągleń używać funkcji ZAOKR(), a nie formatowania komórki (przyciski zmniejsz/zwiększ dziesiętne). Oto przykład, gdy używamy formatowania versus zaokrąglania funkcją:

W kolumnie B jest liczba przed zaokrągleniem, w kolumnie C: zaokrąglenie formatowaniem (zmniejsz dziesiętne), kolumna D: zaokrąglanie funkcją ZAOKR(). Zauważ, że po zsumowaniu liczb w wierszu 4, suma wartości zaokrąglonych funkcją ZAOKR() daje prawidłową sumę, jeśli brać pod uwagę to, co jest wyświetlane. Tak samo dzieje się w wierszu 7. Aby więc zachować spójność między tym co wyświetlane, a tym, co faktycznie znajduje się w komórce – należy używać funkcji ZAOKR() do zaokrąglania liczb!

Artykuły pokrewne:

Spodobał Ci się ten artykuł?

Jeśli TAK, zapisz się na newsletter, aby otrzymywać powiadomienia
o najnowszych wpisach (i tylko powiadomienia: zero spamu).
Dodatkowo otrzymasz DARMOWY EBOOK pt.:

10 najprzydatniejszych porad excelowych


Tagi , , , , , , , , , , , , .Dodaj do zakładek Link.

2 odpowiedzi na „Zaokrąglanie liczb funkcją ZAOKR

  1. jest jakaś funkcja, właśnie jej bezskutecznie szukam, że sumuje to, co widać – w tej sytuacji w kolumnie C4 też pojawiłaby się kwota 2 🙂

    • Malina C. mówi:

      Witaj Dorota,

      jeśli chodzi o funkcję to zaproponowana przeze mnie ZAOKR. Jeśli jednak nie chcesz się nią posługiwać – możesz ustawić to w opcjach:

      Opcje/ Zaawansowane/ Podczas obliczanie w tym skoroszycie/ ustaw dokładność zgodnie z wyświetlaną

      Działa to tak, że jeśli poprzez formatowanie zmienisz dokładność – Excel automatycznie zaokrągli liczbę i „obetnie” to, co było do tej pory zaokrąglane. Np: 1,78 zaokrąglasz do 1 miejsca po przecinku, to Excel wyświetli i zrobi nową liczbę: 1,8.

      Daj znać czy o to chodziło.

      Pozdrawiam
      Malina

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *