fbpx

Film: Suma czasu pracy w projektach wyodrębniana formułą tablicową

19.05.2017 | Czas pracy, Formuły tablicowe, HR, Tylko film

Niedawno pomagałam Leszkowi w zsumowaniu czasu pracy w grafiku, w którym notował przepracowane godziny łącznie z nazwą projektu. Były wiec tam wpisy typu 8A1, gdzie 8 to przepracowane godziny, a A1 to symbol projektu, w którym pracował pracownik. Zaproponowana przeze mnie formuła liczyła łączny czas pracy, a jak się później okazało, Leszek chciał również czas pracy w podziale na projekty. Zmodyfikowałam więc trochę tabelkę wynikową i formuły i udało się to osiągnąć. Jak – o tym jest najnowszy film.

Użyte formuły to:
1. Formuła licząca czas pracy w projekcie:

=SUMA(JEŻELI.BŁĄD(--LEWY($B3:$AF3;SZUKAJ.TEKST(AG$2;$B3:$AF3)-1);0))

2. Łączny czas pracy w miesiącu:

=SUMA(AG3:AH3;B3:AF3)

Oraz plik do pobrania:

 

 

 

Zapisz się na bezpłatny mailing!

Zapisz się na bezpłatny mailing i otrzymaj bezpłatny e-book „10 najprzydatniejszych trików w Excelu”!

Newsletter Malinowy Excel | Bezpłatny e-book
Przeczytaj podobne wpisy

Kategorie

8 komentarzy

  1. Leszek

    Dziękuje Ci bardzo.
    Jesteś niesamowita. Długo nie mogłem poradzić sobie z tym problemem. Dodam jeszcze, że pseudo eksperci od Excela po przeczytaniu mojej prośby zaproponowali rozwiązanie za pieniądze.
    Dobrze, że jeszcze są ludzie pasjonaci. Zyskałaś jeszcze jednego fana.
    Dziękuje raz jeszcze,

    Odpowiedz
    • Malina

      Cieszę się, że o to chodziło 🙂

      Odpowiedz
  2. Ani W.

    Witam serdecznie,Ja szukam rozwiązania do obliczania ilości h, gdy formuła musi uwzględniać czas ponad 24h i wykluczać pracę między 16:00-8:00 oraz weekendy i święta. Wynik powinien być ilością h.
    Chodzi o pomiar czasu na części procesu.
    Np. Data wpływu wniosku
    Data wypływu wniosku
    Chcemy obliczyć ile h zajmuje Pracownikowi zrealizowanie zadania/ czynności, a procesuje dany wniosek nawet kilka dni.

    Będę wdzięczna za pomoc
    pozdrawiam
    Ania

    Odpowiedz
    • Malina

      Tak na szybko mogę polecić ten artyuł. Tam pokazywałam sposób na bliczanie godzin nocnych. Myślę, że tutaj też się przyda 🙂

      Odpowiedz
  3. Kornelia

    Fantastyczne rozwiązanie, akurat takiego potrzebowałam. Jednak kiedy próbowałam zastosować rozwiązanie u siebie, po edycji formuły exel kasował oznaczenia tablicowe { } i wynik formuły wychodzi na 0. Kiedy wpisuję z ręki oznaczenia { } to wychodzi jako tekst i tym bardziej nie mam wyniku 🙁 Co robię źle? Może mam coś źle w ustawieniach? Z góry dziękuję za pomoc.

    Odpowiedz
    • Kornelia

      OK, już znalazłam (trl + Shift + Enter) 😉

      Odpowiedz
      • Malina

        O dokładnie 🙂 Nawet nie zdążyłam odpowiedzieć 🙂

        Odpowiedz
  4. Piolak

    A jak wyglądałaby formuła, jeżeli chciałbym uzyskać dane dotyczące pracy przy np. projekcie A1 ale tylko w określony dzień tygodnia np. sobota dla poszczególnych pracowników. Dziękuję za pomoc.

    Odpowiedz

Wyślij komentarz

Twój adres e-mail nie zostanie opublikowany.

Pin It on Pinterest