fbpx

Obliczanie czasu pracy: przerwy niewliczane do czasu pracy

24.03.2014 | Czas pracy, Daty i czas, HR

Dziś pokażę jak obliczyć czas pracy w przypadku, gdy nie mają być wliczane w niego przerwy. Jest to odpowiedź na pytanie jednego z czytelników mojego bloga, które brzmi tak:

Jak poprawić formułę pokazaną w poście Tygodniowy czas pracy i nadgodziny, jeżeli mam podaną przerwę w pracy np. od 12:00 – 13:00, a nie chcę jej wliczać w łączny czas pracy?

Tak wyglądają dane:

Przerwy niewliczane do czasu pracy - formatka

Pokażę tutaj jak obliczyć czas pracy bez przerw oraz liczbę godzin nadliczbowych. Obliczanie wynagrodzenia znajdziesz w artykule: Tygodniowy czas pracy i nadgodziny.

Aby obliczyć czas pracy należy:

1. W komórce F2 wpisać następującą formułę:

=C2-B2-(E2-D2)

a następnie skopiować ja do pozostałych komórek.

2. W komórce G2 wpisać następującą formułę:

=JEŻELI(F2>=8/24;F2-8/24;0)

a następnie skopiować ja do pozostałych komórek – najlepiej za pomocą kombinacji klawiszy Ctrl + Enter.

Oto wynik:

Przerwy niewliczane do czasu pracy - wynik

I wszystko 🙂

Jeśli interesuje cię znacznie łatwiejsze potraktowanie odliczania przerw od czasu pracy – zachęcam do przeczytania tego artykułu: Jak odliczyć przerwy od przepracowanego czasu? Zachęcam do lektury!

Zapisz się na bezpłatny mailing!

Zapisz się na bezpłatny mailing i otrzymaj bezpłatny e-book „10 najprzydatniejszych trików w Excelu”!

Newsletter Malinowy Excel | Bezpłatny e-book
Przeczytaj podobne wpisy

Kategorie

9 komentarzy

  1. Anonymous

    a jak obliczyć spóźnienia? 🙂 pomocy!!!

    Odpowiedz
    • Malina C.

      A co dokładnie chcesz otrzymać? Jeśli satysfakcjonuje Cię jedynie odliczenie spóźnień od czasu pracy, to postąp analogicznie do tego, jak opisałam w tym artykule. A jak nie – będziemy coś kombinować (tylko koniecznie sprecyzuj) 🙂

      Pozdrawiam
      Malina

      Odpowiedz
    • Anonymous

      nadgodziny działają, proszę o wzór – nie jestem dobra w excelu :/

      Odpowiedz
  2. Anonymous

    nadgodziny działają, proszę o wzór – nie jestem dobra w excelu :/

    Odpowiedz
    • Malina C.

      Co prawda z tego nie korzystam, ale znalazłam, że to po prostu IF. Dizała identycznie jak w Excelu 🙂

      Odpowiedz
    • Łukasz Kobyliński

      Dzięki za odpowiedź. W sumie to sam znalazłem tą funkcję ale nie działała (oczywiście dlatego, że popełniłem błąd 🙂 ). Mam drugie pytanie odnośnie godzin nadliczbowych. Pracuję tylko w nocy i moja zmiana trwa od 22:30 do 7:00 rano i niestety przy tych godzinach funkcja „jeżeli” nie sprawdza się. Jak ją mam zmodyfikować aby liczyło mi nadgodziny?

      Odpowiedz
  3. Bartek

    Wpisując formułę
    =JEŻELI(F2>=8/24;F2-8/24;0)
    Ecxcell zwraca mi same zera.
    Dzieje się tak przy wartościach typu 12:00 w komórce F2
    Przy wartości komórki F2 jest12, to wartości są obliczane prawidłowo.

    Odpowiedz

Wyślij komentarz

Twój adres e-mail nie zostanie opublikowany.

Pin It on Pinterest